azcontrol - Budgets, Product Support is back up – Incident details

All systems operational

Budgets, Product Support is back up

Resolved
Major outage
Started 2 months agoLasted 30 minutes

Affected

Product Support

Operational from 3:27 PM to 3:27 PM, Major outage from 3:27 PM to 3:57 PM

Budgets

Operational from 3:27 PM to 3:27 PM, Major outage from 3:27 PM to 3:57 PM

Updates
  • Resolved
    Resolved
    Budgets, Product Support has been restored by an automated process.
  • Investigating
    Investigating
    Budgets, Product Support are down at the moment. We are investigating the cause, apologize for any inconvenience.